spooln3000
Newly Registered
Posts: 2
Joined: Mon Jun 11, 2012 9:24 pm
Location: Albany NY

Still no flowers

Hello new to site here. I have a lilac bush I planted 4yrs ago and I stilll don't have flowers on it only leafs. It gets enough sun light water etc. I heard they like propheris I added some last yr early and still nothing. When I purchased plant was great flowers buds then first yr nothing only leafs If someone can point me to the right direction Please do so
Thanks for any help

spooln3000
Newly Registered
Posts: 2
Joined: Mon Jun 11, 2012 9:24 pm
Location: Albany NY

Sorry meant to say phosphorus not propheris

User avatar
rainbowgardener
Super Green Thumb
Posts: 25303
Joined: Sun Feb 15, 2009 11:04 pm
Location: TN/GA 7b

Are you fertilizing it? Is it in a lawn? Having too much nitrogen can cause lots of leafy growth at the expense of blooming. Lawn fertilizer is high nitrogen, because for grass you want leafy growth, but if the lilac bush is sitting in the middle of the lawn, it can be getting too much nitrogen.

Do you prune it? Lilac bushes set the buds for next years blooms by the end of summer this year. If you prune after that, any time from about August until when it blooms the following year, you are cutting off the buds and then no flowers. If you prune a lilac, do so right after it blooms (or in late spring right after it would have bloomed).
Twitter account I manage for local Sierra Club: https://twitter.com/CherokeeGroupSC Facebook page I manage for them: https://www.facebook.com/groups/65310596576/ Come and find me and lots of great information, inspiration

Return to “Lilacs Forum”