Bea
Newly Registered
Posts: 3
Joined: Tue Jul 20, 2010 9:58 pm
Location: Brooklyn NY

Japanese Dwarf Andromeda

Hello,
I bought a Japanese Dwarf Andromeda last year full with beautiful white little flowers. However this spring it did not bloom. (only one little stem had flowers)
I have it on a full sun spot, big container, I water it almost daily to keep the soil moist in this heat. The plant looks healthy, just today I noticed tons of new leaves, yet still no flowers.
I'm pretty new at gardening, I would really appreciate any advice I can get.

Thank you!
Bea.
Happiness is a warm puppy on my lap

User avatar
microcollie
Green Thumb
Posts: 319
Joined: Fri Jun 04, 2010 9:17 pm
Location: Western MA

Did you do any pruning last year? They set their buds during the previous year, so should be pruned just after flowering.
Also, their buds are somewhat fragile. I had one in a pretty unprotected spot this spring that got zapped by a frost just as it was coming into bud. (They also don't like wind) Maybe this winter you can move the container to a more protected spot?

Bea
Newly Registered
Posts: 3
Joined: Tue Jul 20, 2010 9:58 pm
Location: Brooklyn NY

I did prune it, but it was my first pruning ever so i might have done a bad job :( On the other hand, it was left outside through the winter, I did not cover it either. No wonder I only had a single stem of flowers and it was at the bottom of the shrub.
Thank you!
I'll make sure to cover it and move it to a protected area this winter.

Bea.
Happiness is a warm puppy on my lap

Bea
Newly Registered
Posts: 3
Joined: Tue Jul 20, 2010 9:58 pm
Location: Brooklyn NY

Do you have a recommendation for a site where I can learn more about properly pruning? Last year I only cut out the dead steams after flowering.

Thank you!
Bea.
Happiness is a warm puppy on my lap

Return to “Trees, Shrubs, and Hedges”