debdog
Newly Registered
Posts: 2
Joined: Sun Jun 10, 2012 12:53 pm
Location: South Pennsylvania

Tomato plants planted 3&1/2 weeks ago and not growing.

:cry: I bought plum tomato plants from a local farmers market about 1 month ago. They were planted about 3&1/2 weeks ago. I have treated them like I would treat a baby ( love and compassion). They have the best organic compost and the best fertilizer, but they have barely moved in size. I have 5 planted and they all look the same. I can see new leaves coming in but they are moving verrrrrry slow. They got plenty of water as well. Everything else in my garden is doing great. Anybody have any idea what's up? Is the type of tomato?

Thanks!

User avatar
rainbowgardener
Super Green Thumb
Posts: 25303
Joined: Sun Feb 15, 2009 11:04 pm
Location: TN/GA 7b

If they are in full sun and not over watered, then you probably just need to be patient a bit more and give them time to get established.

Other than not growing very fast are they looking healthy? Dark green, no yellowing, spotting, curling etc. If they are getting what they need and they are looking healthy, then there's likely not a problem.
Twitter account I manage for local Sierra Club: https://twitter.com/CherokeeGroupSC Facebook page I manage for them: https://www.facebook.com/groups/65310596576/ Come and find me and lots of great information, inspiration

debdog
Newly Registered
Posts: 2
Joined: Sun Jun 10, 2012 12:53 pm
Location: South Pennsylvania

Response

They had some yellow leaves at the base of the plant, but I pruned them off. They are a normal green. There is little unusual bumps along the base of the plant. Not eggs just weird bumps. Other than that, they have at least 6 hours of full sun. Only watering once a day, due to good amount of rain falling.

Thanks!

Return to “TOMATO FORUM”